HMH-Thinkcentral
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Sep 20, 2018 - 13:41 CDT
Update
This issue only impacts students who have had a schedule change since August 27th. All other users should be operational. We continue to work with the vendor to resolve the remaining issues. - JB
Posted Sep 13, 2018 - 11:12 CDT
Identified
We are working with the vendor towards resolving this issue.
Posted Sep 12, 2018 - 17:03 CDT
Update
We are continuing to investigate this issue.
Posted Sep 08, 2018 - 15:19 CDT
Update
We are continuing to investigate this issue.
Posted Sep 07, 2018 - 07:52 CDT
Investigating
We are still working with the vendor on their end. There still may be performance issues.
Posted Sep 07, 2018 - 07:52 CDT
This incident affected: Student Tools (Other Student Tools).