Internet Service Provider Issues
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Oct 27, 2020 - 07:00 CDT
Update
The fault location has been identified. There is not yet an ETA on repairs. -JB
Posted Oct 26, 2020 - 15:59 CDT
Identified
One of our Internet Service Providers has an upstream outage. Services are being re-routed, but performance is impacted.
Posted Oct 26, 2020 - 09:51 CDT
This incident affected: Internet, Network, & Telephone (Internet).