Destiny experiencing technical issues.
Incident Report for Escambia County Public Schools
Resolved
Destiny should be working normally again - TB.
Posted Feb 26, 2020 - 10:36 CST
Investigating
Destiny users may be experiencing problems accessing the applications. IT is aware of the issue and is currently investigating the source of the problems. - TB
Posted Feb 26, 2020 - 10:24 CST
This incident affected: Student Tools (Destiny).