Powerschool/Ed Impact - PJH

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted May 12, 2026 - 13:02 CDT

Investigating

We are aware of an issue affecting Ed Impact/Premium Library and are working with the vendor to resolve.
Posted May 11, 2026 - 11:43 CDT
This incident affected: HR Tools (PowerSchool Products Performance Matters) and Teacher Tools (Other Teacher Tools).