Pearson Products Issue
Incident Report for Escambia County Public Schools
Resolved
This issue has been resolved.
Posted Feb 21, 2020 - 07:29 CST
Identified
This is to alert you of a performance issue within Realize.
We are experiencing intermittent issues impacting logins and access to specific products.
We are aware and actively working to troubleshoot the issues.
We will provide an update as soon as possible.
Posted Feb 19, 2020 - 12:27 CST
This incident affected: Student Tools (Other Student Tools).