Focus - Undergoing Small Update
Incident Report for Escambia County Public Schools
Resolved
The update was successfully applied.
dd
Posted Sep 15, 2018 - 08:17 CDT
Monitoring
A small update is being applied to Focus. You may or may not notice a disruption. This should be complete by 5 pm.
dd
Posted Sep 14, 2018 - 16:13 CDT
This incident affected: Teacher Tools (Focus).