West side schools down
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 08:19 CST
Identified
We have confirmed that there is a fiber cut. There is no ETA on when this will be fixed. We will update the status page as soon as we can. -jsz
Posted Nov 29, 2022 - 15:32 CST
Investigating
The following schools are currently without internet and/or phone:
Warrington es
Warrington ms
Myrtle grove
Navy point
Hope Horizon
Sherwood
Escambia High

No ETA on fix at this time. -jsz
Posted Nov 29, 2022 - 15:00 CST
This incident affected: Internet, Network, & Telephone (Internet, Telephones).