Pine Forest without Power
Incident Report for Escambia County Public Schools
Resolved
Power has been restored to PFHS and the network equipment is being turned back on.
Posted Jun 03, 2020 - 16:47 CDT
Update
PFHS is still without power.
Posted Jun 01, 2020 - 11:17 CDT
Update
Power is still down at PFHS. No ETA on repair as of yet.
Posted May 29, 2020 - 10:21 CDT
Investigating
Power is out at Pine Forest HS.
Posted May 28, 2020 - 12:50 CDT
This incident affected: Internet, Network, & Telephone (Internet, Wireless).