All Systems Operational

About This Site

Welcome to the Escambia County School District Technology Resources Status Page. If you are having technical difficulty with service that is not being shown as down or under maintenance, you can reach the Service Desk at 850.429.2900 or by sending email to ithelp@ecsdfl.us.

Internet, Network, & Telephone ? Operational
90 days ago
99.97 % uptime
Today
IBOSS ? Operational
90 days ago
100.0 % uptime
Today
Internet Operational
90 days ago
100.0 % uptime
Today
Fax Operational
90 days ago
100.0 % uptime
Today
Telephones Operational
90 days ago
99.9 % uptime
Today
Wireless Operational
90 days ago
99.97 % uptime
Today
Email, Calendar, & Collaboration Operational
90 days ago
100.0 % uptime
Today
FILR Operational
90 days ago
100.0 % uptime
Today
GoGuardian Teacher Operational
90 days ago
100.0 % uptime
Today
Google Apps Gmail Operational
90 days ago
100.0 % uptime
Today
Google Apps Calendar Operational
90 days ago
100.0 % uptime
Today
Google Classroom Operational
90 days ago
100.0 % uptime
Today
Google Apps Drive Operational
90 days ago
100.0 % uptime
Today
Google Apps Docs Operational
90 days ago
100.0 % uptime
Today
Google Apps Sheets Operational
90 days ago
100.0 % uptime
Today
Google Apps Sites Operational
90 days ago
100.0 % uptime
Today
Google Apps Slides Operational
90 days ago
100.0 % uptime
Today
Google Meet Operational
90 days ago
100.0 % uptime
Today
IPrint ? Operational
90 days ago
100.0 % uptime
Today
Microsoft Office 365 Operational
90 days ago
100.0 % uptime
Today
MyLinks ? Operational
90 days ago
100.0 % uptime
Today
Blackboard ? Operational
90 days ago
100.0 % uptime
Today
SchoolMessenger Operational
90 days ago
100.0 % uptime
Today
SchoolMessenger Daily Call to Contacts of Absent Students Operational
90 days ago
100.0 % uptime
Today
Teacher Tools Operational
90 days ago
99.99 % uptime
Today
Focus Operational
90 days ago
99.99 % uptime
Today
Schoolnet Operational
90 days ago
100.0 % uptime
Today
PEER Operational
Other Teacher Tools Operational
Student Tools Operational
Accelerated Reader Operational
Algebra Nation Operational
Beanstack Operational
Co:Writer Universal Operational
Destiny Operational
Discovery Education Operational
ESGI Operational
EverFi Operational
HMH Instructional Materials Operational
i-Ready Operational
McGraw-Hill Instructional Materials (ConnectED) Operational
myON Operational
Perfection Learning Operational
QuaverMusic Operational
Renaissance Place Operational
Savvas Instructional Materials (Pearson Realize) Operational
Snap & Read Universal Operational
Star 360 Operational
STEMscopes Operational
Studies Weekly Operational
Suite360 Operational
USATestprep Operational
Waterford Early Learning Operational
Other Student Tools Operational
Finance Tools Operational
Skyward - Finance Operational
Skyward PAC Operational
Kronos Operational
HR Tools Operational
90 days ago
100.0 % uptime
Today
Fieldprint ? Operational
Frontline ? Operational
GMS ? Operational
PowerSchool Products Performance Matters Operational
Skyward - HR Operational
WinOcular Operational
Optiview Operational
90 days ago
100.0 % uptime
Today
Operations Tools Operational
Heartland ? Operational
ProPlan ? Operational
Raptor ? Operational
Safe Schools ? Operational
Transfinder ? Operational
Business Intelligence & Reporting Operational
90 days ago
99.99 % uptime
Today
LiquidOffice Operational
90 days ago
99.99 % uptime
Today
Single Sign-on and User Management Operational
90 days ago
99.98 % uptime
Today
Single Sign On / Authentication ? Operational
90 days ago
99.99 % uptime
Today
Clever SSO ? Operational
90 days ago
99.95 % uptime
Today
Clever SFTP / Other Operational
90 days ago
100.0 % uptime
Today
Clever Portal ? Operational
90 days ago
100.0 % uptime
Today
Technical Support Tools Operational
90 days ago
100.0 % uptime
Today
Zendesk Operational
90 days ago
100.0 % uptime
Today
Statuspage Email Notifications Operational
90 days ago
100.0 % uptime
Today
Statuspage Hosted Pages Operational
90 days ago
100.0 % uptime
Today
Statuspage SMS Notifications Operational
90 days ago
100.0 % uptime
Today
Other Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
FLDOE SSO Applications Unavailable Apr 19, 2024 03:30 - Apr 22, 2024 03:30 CDT
FLDOE will be performing maintenance on their single sign-on portal. All FLDOE SSO Applications including PEER will be unavailable during the maintenance window.
Posted on Apr 18, 2024 - 11:41 CDT
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024
Resolved - McGraw Hill has resolved this issue. All data should now be updated.
-MM IT Integrations

Apr 12, 09:53 CDT
Investigating - New teachers and students added in Focus, as of April 2nd, are not currently showing inside McGraw Hill. We are working with them to resolve the issue.
-MM IT Integrations

Apr 9, 11:28 CDT
Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024
Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Completed - The scheduled maintenance has been completed.
Apr 5, 22:00 CDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 5, 19:00 CDT
Scheduled - The Schoolnet Assessment Platform will be down for planned maintenance and security updates. Planned maintenance helps us ensure the system is functioning correctly to ensure all users get the best experience using the system. Thank you for your patience if you are unable to access the system during the upgrade.
Apr 4, 14:23 CDT
Apr 4, 2024

No incidents reported.