Lincoln Park Elementary-Phone Lines are Down
Incident Report for Escambia County Public Schools
Resolved
Lincoln Park's phone lines have been restored to normal operation.
Posted Oct 11, 2019 - 13:24 CDT
Identified
Lincoln park is currently unable to make or receive phone/fax calls. The phone lines are down on the providers side. We have opened work orders for repair. ~RM
Posted Oct 11, 2019 - 08:22 CDT
This incident affected: Internet, Network, & Telephone (Fax, Telephones).