Telephone Issues at Tate
Incident Report for Escambia County Public Schools
Resolved
The phones are now active and working at Tate. -jsz
Posted Oct 16, 2019 - 09:07 CDT
Investigating
Tate High School is experiencing problems with its telephone systems. IT and the School District are aware and are working to address the issue. - TB
Posted Oct 15, 2019 - 10:54 CDT
This incident affected: Internet, Network, & Telephone (Telephones).