Oakcrest Elementary-Main Phone line is out
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 07:05 CDT
Identified
The main phone line at Oakcrest Elementary is currently down on the providers side. Until the provider restores service, they can be reached at 850-595-6981.
Posted May 28, 2020 - 11:03 CDT
This incident affected: Internet, Network, & Telephone (Telephones).