Pleasant Grove Elementary-Phone Lines Down
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 14:36 CDT
Identified
Pleasant Grove Elementary's phone lines are currently down on the provider's side. The provider is aware and working on the issue. We do not have an ETA for repair at this time. ~RM
Posted Jun 16, 2021 - 07:30 CDT
This incident affected: Internet, Network, & Telephone (Fax, Telephones).