Cordova Park Elementary-Main Phone line is down
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 11:46 CST
Update
We are continuing to work on a fix for this issue.
Posted Nov 30, 2021 - 11:38 CST
Identified
Cordova Park Elementary's main line 850-595-6830 is currently out on the provider's side. A repair order has been placed with the vendor. They can be reached on their secondary line 850-595-6831 until the main line is repaired.
Posted Nov 29, 2021 - 12:12 CST
This incident affected: Internet, Network, & Telephone (Telephones).