IBOSS LOGIN ISSUES
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Nov 21, 2018 - 15:35 CST
Monitoring
Users should now be able to login to IBOSS.-TI
Posted Nov 20, 2018 - 17:14 CST
Identified
There is an issue with IBOSS not letting people sign in. We are currently working with the vendor to correct this problem. We are sorry for the inconvenience. We will update as soon as we can. This is specifically affecting the sign in page for IBOSS.- JS
Posted Nov 20, 2018 - 10:32 CST
This incident affected: Internet, Network, & Telephone (IBOSS).