Pine Meadow Elementary phone lines are down.
Incident Report for Escambia County Public Schools
Resolved
Voice services have been restored to normal.~RM
Posted Sep 17, 2018 - 09:04 CDT
Monitoring
Telephone service has been restored. Monitoring for stabilty.~RM
Posted Sep 14, 2018 - 10:33 CDT
Identified
Pine Meadow Elementary is currently unable to make or receive fax or phone calls. We have contacted the phone line vendor for repair. ~RM
Posted Sep 14, 2018 - 08:29 CDT
This incident affected: Internet, Network, & Telephone (Fax, Telephones).