Clever Issues - iReady and USA TestPrep
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Jul 08, 2021 - 11:59 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2021 - 09:53 CDT
Investigating
We are working with Clever on iReady and USA TestPrep on Summer School updates.
-LC
Posted Jun 09, 2021 - 09:58 CDT
This incident affected: Student Tools (i-Ready, USATestprep).