Cordova Park down
Incident Report for Escambia County Public Schools
Resolved
Cordova Park is now back up and running. Gulf power website shows the problem to be fixed.
Posted Nov 20, 2018 - 08:54 CST
Identified
There is a power outage that is affecting cordova park at this time. We will update when the power has been restored.
Posted Nov 20, 2018 - 08:38 CST