Focus Maintenance Saturday 5/18/19 6:00 a.m. - 7:00 a.m.
Incident Report for Escambia County Public Schools
Resolved
The database server was updated and Focus is fully functional.
Posted May 18, 2019 - 09:17 CDT
Identified
Focus will not be available from 6:00 a.m. until 7:00 a.m. to update their database server.
dd
Posted May 17, 2019 - 15:35 CDT
This incident affected: Teacher Tools (Focus).