Oakcrest Elem Phone Lines
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 12:40 CDT
Identified
Oakcrest Elementary phones can call out but can not receive calls at this time. This has been reported to AT&T.
-LC
Posted Oct 26, 2020 - 11:59 CDT
This incident affected: Internet, Network, & Telephone (Telephones).