District Reports in Focus
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Sep 06, 2018 - 10:39 CDT
Identified
District Reports are not currently available in Focus. Focus has been notified and is working on the solution.
Posted Sep 06, 2018 - 10:13 CDT
This incident affected: Teacher Tools (Focus).