Savvas Realize Performance Degradation
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 07:06 CDT
Investigating
New incident: Investigating
We are currently investigating intermittent performance degradation on Savvas Realize. Users might experience slower performance or intermittent error messages temporarily while we resolve this issue.
Time posted
Sep 17, 11:40 EDT
Components affected
Degraded Performance Realize
Posted Sep 17, 2021 - 11:35 CDT