McGraw Hill World History Books for Students
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 13:59 CDT
Monitoring
All teachers and students should be able to see their textbooks now.
Teachers, be sure to assign the products/textbooks to your classes.
Posted Aug 27, 2021 - 07:16 CDT
Update
We are working with McGraw Hill to resolve the issues of students and classes not showing within the ConnectED programs.
Posted Aug 20, 2021 - 10:29 CDT
Investigating
We are working on issue of books for:
Discovering Our Past: A History of the World-Early Ages, Florida Student Learning Center 2018
Student Edition
Posted Aug 16, 2021 - 08:54 CDT
This incident affected: Student Tools (McGraw-Hill Instructional Materials (ConnectED)).