Sluggish Internet
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Oct 23, 2020 - 17:17 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2020 - 11:26 CDT
Identified
It's not just you. We're currently experience a DDOS event that is causing performance issues. The firewall is stopping the attack, but at the expense of performance. We're working with our internet provider to mitigate.
Posted Oct 23, 2020 - 10:52 CDT
This incident affected: Internet, Network, & Telephone (Internet).