Chrome Browser Randomly Changing Tabs
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 17:21 CST
Investigating
Some users may experience random tab selection while using the Chrome browser or a Chromebook. We are investigating potential solutions.
Posted Jan 08, 2021 - 10:14 CST