Hallcenter Annex down
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 09, 2019 - 08:22 CDT
Identified
Due to roof construction at the hall center, the hall center annex is without internet access, phones, and wireless until further notice
Posted 4 months ago. Jul 05, 2019 - 11:46 CDT