Clever is down
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Nov 09, 2018 - 14:07 CST
Monitoring
Clever reports that they have corrected the problem.
Posted Nov 09, 2018 - 11:24 CST
Update
We are continuing to investigate this issue.
Posted Nov 09, 2018 - 11:23 CST
Investigating
Clever Single Sign-On Downtime
New incident: Investigating
Users are unable to log into the Clever Portal at this time. We are investigating the problem and will post an update shortly.
Posted Nov 09, 2018 - 10:55 CST
This incident affected: Single Sign-on and User Management (Clever Portal) and Student Tools (Other Student Tools).