Incoming call quality issues-Mutiple locations
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 10:30 CDT
Monitoring
The provider is reporting that the call quality issue has been resolved. Monitoring for stability.
Posted Oct 10, 2019 - 14:34 CDT
Identified
Some users are experiencing degraded call quality on incoming calls. The service provider is aware of the problem and is working to resolve the issue.
Posted Oct 09, 2019 - 08:11 CDT
This incident affected: Internet, Network, & Telephone (Telephones).