Tate High School-Currently unable to receive incoming voice or fax calls.
Incident Report for Escambia County School District
Resolved
Voice and fax services have been restored to normal operation. ~RM
Posted 3 months ago. Jul 10, 2019 - 14:09 CDT
Identified
Tate is not currently able to take incoming voice or fax calls due to a provider outage. The provider has been notified of the issue and is working to repair their service.
Posted 3 months ago. Jul 09, 2019 - 16:51 CDT
This incident affected: Voice Services (including telephone and fax) (Telephones, Fax).