Skyward And Skyward PAC Printing issues.
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved - PJH
Posted Jan 14, 2019 - 13:57 CST
Investigating
Currently the district cannot print from Skyward or Skyward PAC. This is a known issue and we have already sent a problem ticket to the Skyward company about this issue.

-WPD
Posted Jan 14, 2019 - 07:33 CST
This incident affected: Finance Tools (Skyward - Finance, Skyward PAC).