Internet Connectivity and Phones Down for Bratt, Ernest Ward, and Northview
Incident Report for Escambia County Public Schools
Resolved
All sites are now operational.
Posted Oct 29, 2020 - 22:18 CDT
Identified
Internet connectivity and phones are down for Bratt, Ernest Ward, and Northview (TI).
Posted Oct 29, 2020 - 16:53 CDT
This incident affected: Internet, Network, & Telephone (Internet, Telephones).