PEER experiencing technical issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 17:38 CDT

Monitoring

From the Florida Department of Education

"The network outage that caused a service interruption with the Florida Department of Education (FDOE) Single Sign-On (SSO) on-premises system has been resolved.

FDOE SSO is back online and available for user login." TI
Posted Mar 17, 2025 - 08:58 CDT

Update

The FLDOE portal itself is reporting login issues. Related applications may be affected; IT is following up.
Posted Mar 14, 2025 - 09:00 CDT

Identified

FLDOE has confirmed that PEER is unavailable.

"A network outage causing Florida Department of Education (FDOE) Single Sign-On (SSO) service interruption." TI
Posted Mar 14, 2025 - 08:45 CDT

Investigating

PEER appears to be non-responsive; initial investigation suggests that it is an issue on the vendor's side. IT will continue to investigate. - TB
Posted Mar 14, 2025 - 08:21 CDT
This incident affected: Teacher Tools (PEER).