The vendor has implemented a fix and we are currently monitoring.
Posted Jul 24, 2026 - 15:00 CDT
Update
We have reached out again to the vendor for an update - we will post any news here as soon as its received.
Posted Jul 23, 2026 - 14:31 CDT
Update
The vendor is continuing to work on finding a resolution to this issue, which is affecting all their customers.
Posted Jul 23, 2026 - 06:07 CDT
Identified
The vendor has identified the issue and is working on a resolution.
Posted Jul 21, 2026 - 08:24 CDT
Update
Skyward is still unavailable. The vendor has not provided an update yet this morning. We will update this page as soon as we have new information.
Posted Jul 21, 2026 - 06:15 CDT
Update
The latest update from the vendor state that these issues are expected to persist until the end of the business day today. Maintenance will continue after 6 PM on July 20, 2026, if necessary. On behalf of them, we sincerely apologize for this inconvenience.
Posted Jul 20, 2026 - 14:43 CDT
Update
The vendor is still working to resolve this issue. They anticipate Skyward may be inaccessible throughout the day on 7/20/2026. Updates will be provided as they become available.
Posted Jul 20, 2026 - 08:45 CDT
Investigating
The vendor has identified that additional maintenance is required, and Skyward is currently unavailable. Please check back here - we will provide updates as they are released.
Posted Jul 20, 2026 - 06:14 CDT
This incident affects: Finance Tools (Skyward - Finance, Skyward PAC) and HR Tools (Skyward - HR).