Parallels MFA Issues

Incident Report for Escambia County Public Schools

Identified

Vendor is actively working on resolving the issues. There isn't an ETA at this time.
Posted Sep 12, 2025 - 14:46 CDT

Investigating

We are experiencing issues with MFA failures for some Parallels users. We are working with the vendor on this issue. - AK
Posted Sep 12, 2025 - 10:48 CDT
This incident affects: Other.