PDP/Evaluation Server down

Incident Report for Escambia County Public Schools

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 10:35 CDT

Investigating

We are currently experiencing a district-wide outage with the PDP/Evaluation Server, which has been identified as a vendor-side issue. We have contacted the vendor, and they are actively investigating the situation.
Posted Jun 02, 2025 - 09:01 CDT
This incident affects: HR Tools (PowerSchool Products Performance Matters).