RenPlace not assigning products
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Feb 23, 2022 - 07:38 CST
Monitoring
Semester 2 courses should be showing now.
Please go in and assign Products.
Posted Jan 06, 2022 - 07:14 CST
Investigating
We are currently working with RenPlace on an issue where some students will sign in and they have no products assigned to them even though products are actually assigned to the classes. We will update this page once we have received a solution. -jsz
Posted Jan 05, 2022 - 07:24 CST
This incident affected: Student Tools (Renaissance Place).