Bellview Elementary-Phone lines are down
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Jun 25, 2022 - 14:09 CDT
Identified
The phone lines are down at Bellview Elementary on the providers side. Repair orders have been created. No ETR at this time~RM.
Posted Jun 23, 2022 - 10:51 CDT
This incident affected: Internet, Network, & Telephone (Fax, Telephones).