Issues with IT Tech Support Line

Incident Report for Escambia County Public Schools

Resolved

The IT Helpdesk line appears to be working normally now.
Posted Jul 17, 2025 - 12:12 CDT

Monitoring

The IT support line now appears to be working normally; we will monitor it for a brief time to ensure continued functionality.
Posted Jul 17, 2025 - 11:06 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 17, 2025 - 11:05 CDT

Identified

IT has confirmed with Zoho that there is a problem at the vendor's end for our Helpdesk phone services. Zoho is investigating further, and we will report updates as more information comes in.
Posted Jul 16, 2025 - 10:58 CDT

Investigating

We are experiencing issues with phone calls made to District IT Tech Support; many of these are not getting through. the situation is being investigated, and we will provide updates as they become available.
Posted Jul 16, 2025 - 09:18 CDT
This incident affected: Technical Support Tools (ZohoDesk).