BoardDocs - Sites Are Inaccessible In The US Region

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 09:14 CDT

Update

The provider is continuing to work on this issue.
Posted Apr 27, 2026 - 11:44 CDT

Identified

From BoardDocs at https://status.diligent.com/incidents/207qkmvtztbf

"Users are unable to access their sites in the US region. We are currently investigating. Thank you for your understanding and patience!"
Posted Apr 27, 2026 - 08:23 CDT
This incident affected: Other.