Imagine Learning

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 11:22 CDT

Investigating

Imagine Learning is currently not allowing access for users. The vendor is looking into the issue for a resolution.
Posted Aug 18, 2025 - 09:05 CDT
This incident affected: Student Tools (Other Student Tools).