Reduced Internet Bandwidth

Incident Report for Escambia County Public Schools

Resolved

Repairs were completed overnight.
Posted Nov 13, 2025 - 06:59 CST

Identified

Per the provider: This is an emergency maintenance event and service should be restored shortly.
Posted Nov 12, 2025 - 16:42 CST

Investigating

One of our Internet service providers is down. We are routing around the issue and do not expect major impacts. -JB
Posted Nov 12, 2025 - 10:56 CST
This incident affected: Internet, Network, & Telephone (Internet).