PEER Deployment and Maintenance, Feb. 24 and 25.

Incident Report for Escambia County Public Schools

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 13:59 CST

Identified

PEER deployment will occur Tuesday, Feb 24th & Peer Maintenance will occur Wednesday, Feb 25th.
-ESE/P. Farmer
Posted Feb 23, 2026 - 13:58 CST
This incident affects: Teacher Tools (PEER).