Problem with ELA-D Evaluations in Talent Ed.

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 12:12 CDT

Investigating

In Talent Ed, Evaluators report that they are not getting the "button" to share and finalize their observation ratings for employees who are on the ELA-D plan. 

An open case with PowerSchool has been made to resolve the issue, and we are awaiting more information. We will try to keep this notice updated as information becomes available. -B.A.
Posted Jun 18, 2025 - 12:12 CDT
This incident affected: HR Tools (PowerSchool Products Performance Matters).