Internet Access Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 19:08 CDT

Monitoring

Full internet connectivity has now been restored. All websites should be functioning normally.
Posted Sep 02, 2026 - 15:00 CDT

Identified

Internet access remains reduced and may impact access to some websites. Skyward remains unavailable. (TI)
Posted Sep 02, 2026 - 14:25 CDT

Investigating

We are currently experiencing reduced internet bandwidth that may impact access. Login to some websites such as Skyward may be impacted (TI).
Posted Sep 02, 2026 - 12:46 CDT
This incident affected: Finance Tools (Skyward - Finance) and Internet, Network, & Telephone (Internet).