Broken Link to CORE App Dashboard

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 10:19 CDT

Identified

The CORE link within Canvas is broken as a result of the website transition. While they work on getting that fixed, you can use the direct link of https://www1.escambia.k12.fl.us/ECSD_Temp/CORE.html
Posted Oct 01, 2025 - 09:57 CDT
This incident affected: Teacher Tools (Other Teacher Tools) and Student Tools (Other Student Tools).