Chrome Casting Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 17:41 CDT

Investigating

We are currently experiencing an issue with Gen 1 and Gen 2 Chromecast devices. It has been reported that this is potentially a global issue and we are in contact with the company attempting to rectify the matter. There is no ETA at this time on the fix. -jsz
Posted Mar 10, 2025 - 11:29 CDT
This incident affected: Teacher Tools (Other Teacher Tools).