Static/noise on outgoing calls to Verizon numbers, issue has re-surfaced.
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Feb 04, 2022 - 07:25 CST
Identified
Many users are experiencing static/clicking when calling numbers on the Verizon network when called from any of our AT&t land lines. This is an area wide issue between service providers. They are aware and are working to get it resolved. ~RM
Posted Jan 27, 2022 - 13:57 CST
This incident affected: Internet, Network, & Telephone (Telephones).