George Stone and Success Academy without Network or Phone Service

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 11:52 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 10:16 CST

Identified

The communication closet is without power. The electricians are working on it.
Posted Jan 22, 2026 - 10:05 CST

Investigating

Network Services is investigating. -JB
Posted Jan 22, 2026 - 09:46 CST
This incident affected: Internet, Network, & Telephone (Telephones).