Bus Stop Locator Tool
Incident Report for Escambia County School District
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 13:59 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2021 - 08:13 CDT
Investigating
We are currently working with Transportation on getting the Bus Stop Locator Tool back up and running. We are sorry for the inconvenience.-jsz
Posted Sep 09, 2021 - 08:12 CDT
This incident affected: Operations Tools (Transfinder).