Latency Issues with Kronos

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 11:53 CDT

Investigating

"It appears some Supervisors are still experiencing latency issues with these two specific areas of Kronos: (1) My Timekeeping>All Current Timesheets and (2) My Employees>Pending Time Off Requests.

During this time, if you are experiencing issues, please expand the "My mailbox" widget to process these requests."
Posted Apr 17, 2025 - 11:46 CDT
This incident affected: Finance Tools (Kronos).